Template Errors: thread_view

  1. The each() function is deprecated. This message will be suppressed on further calls in /usr/www/dgnweb/public/forum/library/XenForo/BbCode/Formatter/Base.php, line 1488:
    1487: 				';
    1488: $__compilerVar55 = '';
    1489: $__compilerVar55 .= 'Select / deselect all posts on this page';

[Solved] usbport.sys dpc latency issues

Discussion in 'Technology' started by everyth1ng, Apr 11, 2016.

Thread Status:
This thread is more than 365 days old.
  1. everyth1ng

    everyth1ng DARKLY Regular

    I suspect that this thread isn't going to get many replies, and it's understandable - drivers can be a bitch to deal with. However, for the life of me, I've been unable to completely eliminate the DPC latency spikes that I've been getting ever since I installed Windows 10 a while ago. Creating this thread is an act of desperation.

    I was having similar issues with my previous set up, but I've been taking a proactive approach with my current set up by trying to address all of my driver related issues head on. I've been very successful with this so far, and the only driver that's still giving me problems is usbport.sys. I'm using LatencyMon to monitor system latency.

    All of my drivers are up to date. I've tried disabling USB controllers, assigning devices to certain IRQs, uninstalling mouse and keyboard drivers, etc, and I'm still getting latency spikes. The only USB devices I'm currently using are my mouse, keyboard, and mic. I've been in and out of the device manager constantly trying to come up with solutions, and the only two things that appear to be using usbport.sys are the two enhanced usb controllers that I have. I tried disabling them, and nothing. What else could be using the usbport.sys driver that I don't know about?

    I thought that maybe because I'm still on the X58 chipset that that might be causing conflicts of some sort, but I've been able to get rid of every other driver related issue that I've come across. I'm at a loss as to what to do to deal with usbport.sys.

    Here are my specs:

    CPU: Intel Core i7-980X @ 4.3 GHz
    GPU: AMD Radeon R9 290
    APU: Asus Essence STX II
    HDD: Western Digital 1 TB Black
    Drive: LG 16x Blu-ray Writer BH16NS40
    RAM: Corsair Vengeance 24 GB DDR3
    PSU: Corsair HX1000W
    Motherboard: Gigabyte EX58-UD5
    Headphones: Beyerdynamic DT 990 Premium - 600 Ohm
    Amplifier: Schiit Magni 2 Uber
    Microphone: Samson Meteor
    Monitor: BenQ XL2720Z @ 144 Hz 1920x1080
    Monitor (Secondary): Samsung SyncMaster 931BW @ 75 Hz 1440x900
    Mouse: Logitech G502 Proteus Core @ 800 DPI 1000 Hz
    Keyboard: SteelSeries Apex [RAW]
    OS: Microsoft Windows 10 Pro

    If anyone has any ideas, please let me know. I appreciate it. Thanks.

    EDIT: Just some additional info. The reason why I'm so concerned about this driver is that I often experience a heavy mouse feeling in CSGO and the desktop. I'm going to refer to it as input lag, but I'm not sure that that's what it is. It's like my mouse has trouble maintaining the 1000 Hz polling rate or something, and it throws off my aim (especially in 28 player servers, for example, where CPU usage is higher than it otherwise would be in a 10 player server). Idling, I can see that CPU usage spikes to around 11% when I move my mouse around on the desktop. When I turn the polling rate down to 500 Hz, CPU usage still spikes up to around 8%. When I look at LatencyMon while moving my mouse around on the desktop I can see ISR count, DPC count, and total execution time skyrocket for usbport.sys.

    TL;DR: usbport.sys is being a cunt and won't go away. Please advise.
    Last edited: Apr 11, 2016
  2. Sushicutter

    Sushicutter TD Admin

  3. up-n-atom

    up-n-atom DARKLY Regular

    Do you have any of those "enhancing" Gigabyte tools installed? If you do start by removing them. Although you're seeing a single anomaly it may be caused by a deadlock from another driver. Disable everything you don't use in BIOS as well as everything you seldom use and enable 1 by 1 after testing. Try different USB ports and try to stick with the same USB versioned port to hardware.
  4. everyth1ng

    everyth1ng DARKLY Regular

    No, I don't have any Gigabyte tools installed. Also, I flashed my motherboard to F13 (the most recent version) around the time that I installed Windows 10. I've disabled a ton of stuff in BIOS already. I'll post some pictures for you so that you can see what I've already done (3 pictures):
    I disabled HPET a while ago and it drastically reduced DPC latency for a number of different drivers, but my understanding is that disabling it doesn't always produce the same results on other hardware. Definitely worked for me, though.

    I put my HDD in AHCI mode yesterday because I was getting latency spikes from ataport.sys, and doing that completely resolved the issue. That was the last tweak I did to my system before posting here.

    I'll keep experimenting with the USB controllers, but haven't had any good results so far. I'm not sure where else to look, to be honest. Please let me know if you have any ideas.

    Thanks a lot!
    Last edited: Apr 12, 2016
  5. Thanatos

    Thanatos TD Member

    Stupid question: Have you tried your mouse in a different USB port? Both front and back?

    Also, do you have Logitech Gaming Software installed? Have you tried uninstalling it and seeing if there's a difference?
  6. up-n-atom

    up-n-atom DARKLY Regular

    It's hard issue to fix without seeing for yourself and possible hours to investigate. Personally I would enable 64bit HPET but I've heard Windows may have issues if utilizing it and the possibility of bad hardware implementations. Was AHCI not default? That's shockingly terrible if not these days. I would enable SATA Native Mode, it's been supported since Windows XP I believe. Any reason you have CPU Multi-Threading aka Hyper-Threading disabled? It shouldn't have a negative impact with overclocking and will benefit SMT workloads. Not sure if you've done it or not but un-check Enhanced Pointer Precision in Mouse Properties in Windows, it could be the cause for your heavy mouse feel.
    Last edited: Apr 12, 2016
  7. everyth1ng

    everyth1ng DARKLY Regular

    Yeah, AHCI wasn't on by default.

    Regarding Hyper-Threading, I had it enabled until as recently as last week. I turned it off because I heard that it was bad in combination with HPET disabled, although I had been running Hyper-Threading enabled and HPET disabled for a while with no issues.

    And I always check to see that Enhance Pointer Precision is un-checked. It's definitely not that.

    @Thanatos , yeah, I've tried my mouse in every port. I've tried disabling all of the USB controllers to see if usbport.sys still shows up high in LatencyMon, and it still does. I've tried uninstalling Logitech Gaming Software, and there's no difference. Right now I have it installed but not running in the background. The mouse saves my mouse profile, so I don't need it running in the background for any reason as far as I know.
    Last edited: Apr 12, 2016
  8. Thanatos

    Thanatos TD Member

    You don't have both Setpoint and Logitech Gaming Software installed do you?

    Also, and this is also a stupid question, but have you tried turning down the polling rate on your mouse?
  9. everyth1ng

    everyth1ng DARKLY Regular

    No, I don't have Setpoint installed.

    And yes, I've experimented with both 500 Hz and 1000 Hz. CPU usage is slightly lower with 500 Hz, but it doesn't feel as smooth in game (although that smoothness is very inconsistent).
  10. everyth1ng

    everyth1ng DARKLY Regular

    Yeah, I was dealing with the heavy mouse feeling in TD all night tonight. I wish I knew what to do to fix this. It's bothering me so much. Sometimes it's not that bad, though.

  11. Thanatos

    Thanatos TD Member

    Does it happen in similar hl2 based games? Have you tried going into TF2 and joining a 32 man server and seeing if you can replicate or is it just limited to CS?
  12. everyth1ng

    everyth1ng DARKLY Regular

    I haven't played TF2 in years, to be honest.

    CSGO seems to be particularly susceptible to performance issues because it's so reliant on CPU resources. And because CSGO is CPU limited, it also benefits greatly from CPU overclocking. However, if your system isn't in good health, it's going to show in CSGO. Big time. Some people are more sensitive to input lag, micro stuttering, etc., than others, but I also think that many people aren't as bad at CSGO as they think they are. If they we're to run the game on a well optimized system, replete with CPU resources, I think that they'd find themselves performing MUCH better in game. I need CSGO to feel snappy and responsive, and it doesn't feel like that for me at the moment, and it's like having an itch that you can never scratch.

    usbport.sys seem to only be using Core 0. I wonder if setting affinity for CSGO to Cores 1, 2, 3, 4, and 5, and leaving Core 0 unchecked would help to mitigate the problem. I'll test this and report back. Kind of a band-aid solution, but it's all I've got at the moment.
    Last edited: Apr 13, 2016
  13. OG buckshot jr

    OG buckshot jr TD Admin

    Thanks for tagging me in @Sushicutter . Just read this thread so I'll do my best not to repeat possible avenues to investigate. I'll start by just throwing this out there: Win10 has a fuckload of drivers issues, and if you can, uninstall it. It really is that bad.

    Now that I have that out of the way, first thing I'm going to suggest is this - turn your PC off and disconnect your monstrous soundcard. Reboot, and use Windows' built-in soundcard to handle your sound. Give it a test, game a bit, and monitor latency. Try not to let the numbers play with your 'feel' - maybe don't check the numbers until you game for 15 mins to see if it 'feels' better, than check the numbers to validate.

    [Alternatively to the bit below, disable the [internal] USB headers you're not using on your motherboard - your BIOS should allow you to do this.]

    Possible Solution via SevenForums,
    - Note, you will lose a pair of USB ports the moment you disable one of the USB drivers that are installed. The key thing here is that you disable, not uninstall - we all know Windows loves to re-install shit immediately.

    Disable all power management; both in your BIOS for your CPU, and in your Control Panel -> Power Options (use Categorized View for direct access). In particular, go into the current power profile's 'Advanced Settings' and ensure "USB Suspend" and anything related is disabled. I'm not sure of all the views and file paths of Win10, but you're a smart guy and you'll figure out what I'm saying (I have no idea if Win10 is any different than 7).

    Let me think and dig more before I provide more suggestions..
  14. everyth1ng

    everyth1ng DARKLY Regular

    First of all - thanks for your help. If you have any ideas, please share them. I really appreciate it.

    In the OP, I probably should have listed everything that I've already tried, but there are TONS of things that I've already tried. It's getting pretty ridiculous, actually.

    I've previously gone through all of the USB controllers to find the ones that use usbport.sys, and only two of them use that particular driver. The two USB controllers with usbport.sys are named Enhanced Host Controllers, whereas the USB controllers without usbport.sys are named Universal Host Controllers. Disabling the Enhanced Host Controllers has no effect. I still see ISR count, DPC count, and total execution numbers skyrocket in LatencyMon as if I never disabled anything.

    When I go into BIOS, all I see regarding USB controller settings is what you see above in the second picture that I posted. There is no section where I can enable/disable individual controllers. I only have the single enable/disable USB controllers option listed above. What kind of bullshit is that? Strangely, though, in my motherboard user manual, I see individual options for disabling USB 1.0 and USB 2.0 controllers. I wish that I had a PS/2 keyboard so that I could select disable and see if the usbport.sys issue is resolved.

    Regarding Power Options, already done. I'm on high performance, and in the advanced settings I have USB selective suspend disabled and processor power management min/max states at 100%. Is there anything else that I'm missing in there? I'm also not sure if I'm missing anything in BIOS regarding power management. I believe I have everything disabled.

    @up-n-atom , FYI, I enabled SATA Native Mode. Regarding AHCI, I don't really notice any performance improvements so far, but I'm certainly glad that the ataport.sys driver issue is resolved.

    OG buckshor jr or anyone else, please let me know if I'm missing anything here. I'm kind of learning as I go, and I'm desperate to resolve the usbport.sys driver issue. I've googled for days, and I mostly just see dead end threads with no solution. I've skimmed through all 265 pages of this thread, too: http://www.overclock.net/t/1433882/...ios-optimization-guide-for-modern-pc-hardware, and I still don't have a solution. And I don't worry, I'm not following all of the advice listed in the OP. An updated version of the OP was posted here, FYI: http://steamcommunity.com/sharedfiles/filedetails/?id=607576835

    Regarding the sound card, I do have a low latency version of the Unified Drivers installed instead of the official Asus drivers. The drivers can be found here: http://maxedtech.com/asus-xonar-unified-drivers/

    I should post some screen caps of LatencyMon for everyone to see. Would that be useful? usbport.sys seem to be the only red flag, but perhaps I'm missing something.
    Last edited: Apr 14, 2016
    OG buckshot jr likes this.
  15. OG buckshot jr

    OG buckshot jr TD Admin

    Sorry I missed some of what you've already done, I was on the shitter lol I don't wanna waste your time.

    Seems you've done a fuckload of work already, so don't beat yourself up. I've never tested something like latency, I'd be curious if something similar exists on my PC as I've got like 24 USB ports (most of them in use, believe it or not).. Maybe I'm scared to find out lol

    I did read there was another latency monitoring program that's popular and apparently that one and the one you use don't always yield the same results. As frustrating as this may sound, give it a shot to ensure you're not chasing a red haring. In the meantime, back to research I go.

    And yes! More screen-shots/information is always better; it may help me search with you and may trigger a black-magic thought and hopefully we'll get lucky.

    Cheers, and good luck!
  16. everyth1ng

    everyth1ng DARKLY Regular

    If you're anything like me, you'll obsess over any problem you come across to the detriment of everything else around you. I wouldn't recommend it, lol.

    Here are two screen captures taken after 1 minute of running LatencyMon. This is idle, keeping my mouse completely still:
    This is a second test on the same boot. Again, LatencyMon running for 1 minute. This time, however, I'm sitting on the desktop moving my mouse around:
    Something is seriously fucked up here, wouldn't you say? I should also mention that I have audio crackling at high volume, too.
    Last edited: Apr 14, 2016
  17. everyth1ng

    everyth1ng DARKLY Regular

    OG buckshot jr likes this.
  18. OG buckshot jr

    OG buckshot jr TD Admin

  19. everyth1ng

    everyth1ng DARKLY Regular

    No worries, man. I'm very busy myself, as I'm supposed to be studying for finals and finishing up an assignment.

    I think a lot of people could stand to benefit from this thread if someone here comes up with a solution. I honestly don't care if it's me who comes up with the solution or someone else. I just want it fixed. I'll keep looking when I can.
    Last edited: Apr 17, 2016
    OG buckshot jr likes this.
  20. everyth1ng

    everyth1ng DARKLY Regular

    Possible work around - purchase a PCIe internal USB 3.0 card and completely disable USB 2.0 on my motherboard. But what drivers would I use for the card? Not sure if this would work.
Thread Status:
This thread is more than 365 days old.

Share This Page